Subject: [GSOC PATCH 0/2] commit: improve behaviour of core.commentChar=auto for comments in commit messages

From: Ayush Chandekar <[email-masked]>
Date: Wed, 16 Jul 2025 00:21:24 +0530

Hey everyone,

The aim of this patch series is to improve the behaviour of core.commentChar=auto by the following patches:
1/2 - Fix a bug which reads comment character of the comments in commit message leading to change in the value of `comment_line_str` and thus resulting the comments in the final commit message.
2/2 - Standardizes the behaviour of code by resetting the 'comment_line_str' to "#" when core.commentChar is set to auto. 

Thanks to Junio, Phillip and Kristoffer for reviewing the patches and also Christian for the reviews and mentoring me.

Ayush Chandekar (2):
  commit: avoid scanning trailing comments when 'core.commentChar' is
    "auto"
  config: set comment_line_str to "#" when core.commentChar=auto

 builtin/commit.c           |  6 +++++-
 config.c                   |  6 ++++--
 t/t3418-rebase-continue.sh | 13 +++++++++++++
 3 files changed, 22 insertions(+), 3 deletions(-)

-- 
2.49.0

---

From: Ayush Chandekar <[email-masked]>
Date: Wed, 16 Jul 2025 00:26:59 +0530

**Please ignore the patch series sent before this, accidentally missed out on mentioning the verison 'v4' in the subject.**

Hey everyone,

The aim of this patch series is to improve the behaviour of core.commentChar=auto by the following patches:
1/2 - Fix a bug which reads comment character of the comments in commit message leading to change in the value of `comment_line_str` and thus resulting the comments in the final commit message.
2/2 - Standardizes the behaviour of code by resetting the 'comment_line_str' to "#" when 'core.commentChar' is set to "auto". 

Ayush Chandekar (2):

-- 
2.49.0