Subject: Re: [PATCH v15 2/9] namei: LOOKUP_NO_MAGICLINKS: block magic-link resolution

From: Al Viro <[email-masked]>
Date: Wed, 13 Nov 2019 01:24:26 +0000

On Tue, Nov 05, 2019 at 08:05:46PM +1100, Aleksa Sarai wrote:
> @@ -1078,6 +1079,10 @@ const char *get_link(struct nameidata *nd)
>  		} else {
>  			res = get(dentry, inode, &last->done);
>  		}
> +		if (nd->flags & LOOKUP_MAGICLINK_JUMPED) {
> +			if (unlikely(nd->flags & LOOKUP_NO_MAGICLINKS))
> +				return ERR_PTR(-ELOOP);
> +		}

Minor nit - the first check probably wants unlikely() more than the
second one; it's probably noise anyway, but most of the symlinks
traversed are not going to be procfs ones, so you get test + branch
taken most of the time.

OTOH, that just might compile into
	fetch nd->flags
	and with LOOKUP_MAGICLINK_JUMPED | LOOKUP_NO_MAGICLINKS
	compare with the same constant
	unlikely branch when equal

Anyway, that's no more than a minor nit and can be dealt with later (if
at all)

_______________________________________________
linux-arm-kernel mailing list
[email-masked]
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

---

From: Al Viro <[email-masked]>
Date: Wed, 13 Nov 2019 01:24:26 +0000