Subject: Re: [PATCH 20/20] cw1200: drop useless LIST_HEAD

From: Kalle Valo <[email-masked]>
Date: Thu, 10 Jan 2019 11:36:07 +0000 (UTC)

Julia Lawall <[email-masked]> wrote:

> Drop LIST_HEAD where the variable it declares has never
> been used.
> 
> The semantic patch that fixes this problem is as follows:
> (http://coccinelle.lip6.fr/)
> 
> // <smpl>
> @@
> identifier x;
> @@
> - LIST_HEAD(x);
>   ... when != x
> // </smpl>
> 
> Fixes: a910e4a94f692 ("cw1200: add driver for the ST-E CW1100 & CW1200 WLAN chipsets")
> Signed-off-by: Julia Lawall <[email-masked]>

Patch applied to wireless-drivers-next.git, thanks.

06605b0d38b4 cw1200: drop useless LIST_HEAD

-- 
https://patchwork.kernel.org/patch/10741603/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

---

From: Kalle Valo <[email-masked]>
Date: Thu, 10 Jan 2019 11:36:07 +0000 (UTC)