Subject: Re: [PATCH net] net: phy: guard against accessing a NULL features bitmap

From: Andrew Lunn <[email-masked]>
Date: Fri, 11 Jan 2019 15:19:32 +0100

> > Hi Camelia
> > 
> > A NULL features is a driver bug. So i would prefer to solve this
> > differently.
> >
> > Please make phy_driver_register() do a WARN_ON(!new_driver->features)
> > and return -EINVAL.
> 
> I wasn't aware that features are mandatory. I'll make the change.

It was not origionally, but really it should be now.

> Yes, there are five drivers that don't have features configured: BCM8706, BCM8727, CS4340, TN2020 and KSZ8873MLL.

> I'm planning to send patches on net-next for the Cortina and
> Teranetics ones at least, but fixing the generic crash was my
> priority.

O.K, will take the others.

Thanks
	Andrew

---

From: Andrew Lunn <[email-masked]>
Date: Fri, 11 Jan 2019 15:19:32 +0100

Thanks
	Andrew