Subject: Re: [PATCH net-next v4] Documentation: networking: Clarify switchdev devices behavior

From: Ido Schimmel <[email-masked]>
Date: Fri, 11 Jan 2019 15:53:08 +0000

On Fri, Jan 11, 2019 at 04:43:31PM +0100, Andrew Lunn wrote:
> > > +IGMP snooping
> > > +~~~~~~~~~~~~~
> > > +
> > > +The Linux bridge allows the configuration of IGMP snooping (compile and run
> > > +time) which must be observed by the underlying switchdev network device/hardware
> > > +in the following way:
> > > +
> > > +- when IGMP snooping is turned off, multicast traffic must be flooded to all
> > > +  switch ports within the same broadcast domain. The CPU/management port
> > > +  should ideally not be flooded and continue to learn multicast traffic through
> > > +  the network stack notifications. If the hardware is not capable of doing that
> > > +  then the CPU/management port must also be flooded and multicast filtering
> > > +  happens in software.
> > > +
> > > +- when IGMP snooping is turned on, multicast traffic must selectively flow
> > > +  to the appropriate network ports (including CPU/management port) and not flood
> > > +  the switch.
> > > +
> > > +Note: reserved multicast addresses (e.g.: BPDUs) as well as Local Network
> > > +Control block (224.0.0.0 - 224.0.0.255) do not require IGMP and should always
> > > +be flooded.
> > 
> > I'm not sure that these paragraphs are actually needed. You're basically
> > describing RFC 4541 on which the IGMP snooping functionality in the
> > Linux bridge is based on.
> 
> Hi Ido
> 
> My experience talking with people is that IGMP snooping is a bit
> mystical and not well understood. I would not be surprised if
> community driver writers, as opposed to vendor driver writers, don't
> actually know how snooping works. So i find having some hints is good.

Can we at least mention this RFC is the doc? It's very well written IMO

---

From: Ido Schimmel <[email-masked]>
Date: Fri, 11 Jan 2019 15:53:08 +0000